jump to navigation

Using CISCO IOS AUX port to access the console port on another device (reverse telnet) May 16, 2009

Posted by daakeung in Uncategorized.
Tags: , , ,
4 comments

Setup a loopback interface:

int lo 1
ip address 10.1.1.1 255.255.255.255

line aux 0
transport input telnet
speed 9600

To access the aux interface, you telnet to the loopback address on port 2000+line#

for example:

sh line
Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int
0 CTY              –    –      –    –    –      0       0     0/0       –
I    1 TTY              – inout     –    –    –      0       0     0/0       –
5 AUX   9600/9600  – inout     –    –    –      0       0     0/0       –
*    6 VTY              –    –      –    –    –     78       0     0/0       –
7 VTY              –    –      –    –    –      2       0     0/0       –
8 VTY              –    –      –    –    –      0       0     0/0       –
9 VTY              –    –      –    –    –      0       0     0/0       –
10 VTY              –    –      –    –    –      0       0     0/0       –

telnet 10.1.1.1 2005

***UPDATED***

Advertisements

Using Cisco IOS to determine Serial Number May 8, 2009

Posted by daakeung in Cisco, IT.
Tags: , , , ,
add a comment

Have any of you ever had to find out the S/N of a remote cisco ios device?

You can issue the following IOS command:

show inventory

This produces the PID, the MODEL number of the device and also the Serial Number, this can be useful when auditing your network.

Setting up onboard Dialout v.92 modem on cisco 1811 April 9, 2009

Posted by daakeung in Cisco, IT.
Tags: , , , ,
add a comment

I’ve trolled the internet looking for ways to configure the v92 modem on a cisco 1811, and have managed to paste together pieces to make a dialup connection from the router, please note this configuration will not work with the aux port.

interface Async1
no ip address
ip nat outside
ip virtual-reassembly
encapsulation ppp
no ip route-cache cef
no ip route-cache
dialer in-band
dialer pool-member 1
dialer-group 1
async mode interactive

!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
no ip route-cache cef
no ip route-cache
dialer pool 1
dialer remote-name ***ISP NAME***
dialer idle-timeout 2000
dialer string ***NUMBER***
dialer hold-queue 10
dialer-group 1
no peer default ip address
ppp authentication pap chap callin
ppp chap hostname ***USERNAME***
ppp chap password 0 ***PASSWORD***
!

access-list 123 permit ip any any — Modify this to mark interesting traffic to bring up the Dialup Connection.
dialer-list 1 protocol ip list 123

Enabling SSH on cisco IOS March 12, 2009

Posted by daakeung in Cisco.
Tags: , ,
add a comment

As many of you know, telnet is unsecured when configuring remote devices. Any intruder can read the information in plain text.

The secure alternative is SSH.

SSH provides encryption of your commands as well as the user/passwords.

To configure ssh on cisco ios, first define a hostname and domain name:

Router(config)#hostname test
test(config)#ip domain name akeung.com

Define local account

test(config)# username darryl password test

Set aaa new model

test(config)#aaa new-model

Generate Key

test(config)#crypto key generate rsa
The name for the keys will be: test.akeung.com
Choose the size of the key modulus in the range of 360 to 2048 for your
General Purpose Keys. Choosing a key modulus greater than 512 may take
a few minutes.

How many bits in the modulus [512]: 1024
% Generating 1024 bit RSA keys, keys will be non-exportable…[OK]

Set SSH to version 2

test(config)#ip ssh version 2

Set SSH authentication retries

test(config)#ip ssh authentication-retries 3

And finally, change the transport for telnet to SSH

test(config-line)#line vt 0 4
test(config-line)#transport input ssh