jump to navigation

Using Cisco IOS to determine Serial Number May 8, 2009

Posted by daakeung in Cisco, IT.
Tags: , , , ,
add a comment

Have any of you ever had to find out the S/N of a remote cisco ios device?

You can issue the following IOS command:

show inventory

This produces the PID, the MODEL number of the device and also the Serial Number, this can be useful when auditing your network.

Advertisements

Small Business Server 2003 POP3 Connector April 19, 2009

Posted by Gomez in E-Mail, IT, Microsoft.
Tags: , , , , ,
1 comment so far

Small Business Server 2003 users that use the POP3  Connector Manager and are affected by that annoying 15 minutes download interval, finally there is hope, here is a registry tweak to drop the interval from 15 minutes to 5 minutes;

FIRST. Take a backup of your registry

1. Open Regedit
2. Navigate to HKEY_LOCAL_MACHINE/SOFTWARE/Micro­ soft/SmallBusinessServer/Network/P­OP3 Connector
3. Create a new “DWORD value” and type “ScheduleAccelerator” as the entry name
4. Select the DWORD and on the edit menu click modify, in the value box, type 3 and ensure the Decimal Radio button is clicked on the right.

(To determine the polling interval, the value that is configured on the “Scheduling” tab in the GUI is divided by the value that you type for the ScheduleAccelerator entry, example, if a 15 minute interval is specified in the GUI and you set the value of the ScheduleAccelerator entry to 3, the connector will poll ever five minutes, If you make it too short there can be problems with the POP3 connector starting a download before the previous download has started, it seems to work well with 5minutes)

5. Exit Regedit

HTTP/1.1 503 Service Unavailable April 9, 2009

Posted by Gomez in E-Mail, IT, Microsoft, Network Services.
Tags: , , ,
3 comments

After typing http://Server-name/exchange
You get the login box, after entering the correct user info you get the dreaded
HTTP/1.1 503 Service Unavailable, after searching the web for months and tried almost all available tutorials I finally found the solution. This problem (the scenario I experienced) it relates to permissions in the windows registry. Follow the steps below to get OWA working as normal.

1. Open regedit from the command prompt, ensure you take a backup of your current registry configuration. To export, on the file menu in registry editor click export  and choose save destination

2. Locate and Right Click HKEY_CLASSES_ROOT hive and select Permissions

3. Click the Advanced button on the Permissions dialog box

4. Highlight CREATOR OWNER – make sure this is the user selected

5. Tick the box for Replace permission entries on all child objects

6. Click OK twice

7. Its best to restart the server, but if you are anxious just restart all exchange services

8. Finally Test 
 
 
 

 

Setting up onboard Dialout v.92 modem on cisco 1811 April 9, 2009

Posted by daakeung in Cisco, IT.
Tags: , , , ,
add a comment

I’ve trolled the internet looking for ways to configure the v92 modem on a cisco 1811, and have managed to paste together pieces to make a dialup connection from the router, please note this configuration will not work with the aux port.

interface Async1
no ip address
ip nat outside
ip virtual-reassembly
encapsulation ppp
no ip route-cache cef
no ip route-cache
dialer in-band
dialer pool-member 1
dialer-group 1
async mode interactive

!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
no ip route-cache cef
no ip route-cache
dialer pool 1
dialer remote-name ***ISP NAME***
dialer idle-timeout 2000
dialer string ***NUMBER***
dialer hold-queue 10
dialer-group 1
no peer default ip address
ppp authentication pap chap callin
ppp chap hostname ***USERNAME***
ppp chap password 0 ***PASSWORD***
!

access-list 123 permit ip any any — Modify this to mark interesting traffic to bring up the Dialup Connection.
dialer-list 1 protocol ip list 123

VMWARE ESX Command Line Guide March 13, 2009

Posted by daakeung in Uncategorized, Virtualization, Vmware ESX.
Tags: , , ,
add a comment

I came across this useful list of command line tutorials for various ESX configuration and diagnostic utilities.

http://www.b2v.co.uk/b2vguide2vmware.htm

Enabling SSH on cisco IOS March 12, 2009

Posted by daakeung in Cisco.
Tags: , ,
add a comment

As many of you know, telnet is unsecured when configuring remote devices. Any intruder can read the information in plain text.

The secure alternative is SSH.

SSH provides encryption of your commands as well as the user/passwords.

To configure ssh on cisco ios, first define a hostname and domain name:

Router(config)#hostname test
test(config)#ip domain name akeung.com

Define local account

test(config)# username darryl password test

Set aaa new model

test(config)#aaa new-model

Generate Key

test(config)#crypto key generate rsa
The name for the keys will be: test.akeung.com
Choose the size of the key modulus in the range of 360 to 2048 for your
General Purpose Keys. Choosing a key modulus greater than 512 may take
a few minutes.

How many bits in the modulus [512]: 1024
% Generating 1024 bit RSA keys, keys will be non-exportable…[OK]

Set SSH to version 2

test(config)#ip ssh version 2

Set SSH authentication retries

test(config)#ip ssh authentication-retries 3

And finally, change the transport for telnet to SSH

test(config-line)#line vt 0 4
test(config-line)#transport input ssh


Changing the store limits in Exchange 2003 Standard SP2 March 9, 2009

Posted by Gomez in E-Mail, IT, Microsoft.
Tags: , , ,
1 comment so far

Just a few months ago, i encountered several errors messages in event viewer regarding MS Exchange Information Store,  I found that my clients exchange database had grown to 17GB, to fix this issue i installed Service Pack2 for exchange which allows the store limt to grow but does not change from default (16GB), below is the method to increase to store limt from 16GB to 75GB (maximum).

1. On the computer running Exchange Server, start Regedit.exe.

To configure the database size limit on a mailbox store, use the following registry key:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\Server name\Private-Mailbox Store GUID

Create a new DWORD entry called “Database Size Limit in Gb” and give it the appropriate value for maximum database size in GB. For Exchange Server 2003 Standard Edition type a value between 1 and 75 (the value represents in GB). For Exchange Server 2003 Enterprise Edition type a value between 1 and 8000 (the default is 8000 GB). Click OK.

Note: Entries should be in decimal format.

Create a new DWORD entry called “Database Size Buffer in Percentage” and give it the appropriate value between 1 and 100 to specify when you want events to be logged in the application log in Event Viewer to warn you that you are nearing the maximum size for a database.

The default value of 10 (i.e. 10%) will result in warning events to be logged when you have 10 percent capacity left before you reach the maximum size for that database.

Create a new DWORD entry called “Database Size Check Start Time in Hours From Midnight” and give it the appropriate value between 0 and 23 to specify when you want Exchange to check the database size. The default value of 5 results in Exchange Server checking the database size 5 hours after midnight (i.e. 5:00 AM).

Close Registry Editor.

For this patch to work you must dismount your information store and remount, a reboot seems to work best.

How to enable Remote Desktop remotely February 28, 2009

Posted by daakeung in Microsoft.
Tags: , , ,
2 comments

Have you ever wanted to enable RDP remotely on a windows xp remote system ?

You can connect to the remote registry using regedit and change the fDenyTSConnection value from 1 to 0 under

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal

this would enable RDP on the destination computer.

For some administrators, you might want to roll this setting out to active directory clients.

You can push this registry file out silently using the following reg file

——————————————————————————————————

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server]

“fDenyTSConnections”=dword:00000000

——————————————————————————————————

running regedit silently:

regedit /s rdp.reg

Resetting TCP/IP in Windows XP February 16, 2009

Posted by daakeung in IT, Microsoft.
Tags: , ,
add a comment

I have recently gotten a problem on my laptop, where I get this message

“the network location cannot be reached. for information about network troubleshooting, see windows help”

when accessing network shares.

Sometimes TCP/IP Stack gets corrupted. Since this is a core part of the OS, reinstallation is not possible.

However you can reset the TCP/IP stack using this command.

netsh int ip reset c:\reset.txt

This will reset the TCP/IP stack in windows XP.

You can read more about this here : http://support.microsoft.com/default.aspx?scid=kb;en-us;299357&Product=winxp

ISA Server 2006 enterprise edition corrupted rule. January 26, 2009

Posted by daakeung in ISA Server, IT.
Tags: , , ,
14 comments


Recently, ISA server had stop loading the firewall rules since it had become corrupted.

To remove the rule, you first need to find the GUID of the rule.  Just search your registry for the rule and you will find the GUID associated with it.

Once you have the GUID, you then need to install ADAM ADSI EDIT

Connect to local host on port 2171

CN=FPC2

Then drill down through the arrays until you find that specific GUID and delete it.

That resolved the issue.

The reason why the rule became corrupt, I had 2 sessions to the ISA server with the firewall management opened.

I deleted the rule from one session and tried to disable it on the other. After which it stopped me from viewing the firewall rules.

Hope this helps someone.