jump to navigation

SQL [sqlservr.exe] Memory Consumption on Small Business Server July 7, 2009

Posted by Gomez in IT, Microsoft, Performance & Alerts.
Tags: , , , ,
3 comments

I started receiving alarms that pages/sec on my client’s SBS Server was 6952.92 pages/sec. Please note that Microsoft Best Practices recommends no more than 20 pages/sec.
I found that sqlservr.exe was consuming in excess of 1.5GB of memory. This is been a known issues for Servers running Small Business Server, I will walk you through the process of reducing usage for this memory thirsty process.

1. Open Task Manager > Processes Tab, View Menu > Columns, select PID check box.
2. In the list of processes locate the sqlservr.exe process that is consuming the most memory (there might be multiple instances of sqlservr.exe) take note of the PID number next to the memory thirsty process.
3. Open a command prompt and issue the following command without the quotes,
    “tasklist /svc” (this is used to display running processes (PIDs) and applications)
     next to the PID number previously identified in taskmanager take note of the service name.
   The service would be MSSQL$SBSMONITORING.

4. At the command prompt issue the following commands, after each command press enter;
   
 Command 1: osql -E -S SERVERNAME\sbsmonitoring  
(replace SERVERNAME with the hostname of your server, sbsmonitoring is the service name )
 Command 2: sp_configure ‘show advanced options’,1
 Command 3: reconfigure with override
 Command 4: go

Command 1: sp_configure ‘max server memory’, 200
(200 represent memory size in MB, replace 200 with any memory size you wish, default is 2147483648)
 Command 2: reconfigure with override
 Command 3: go

 After the last command “Go” you should see a confirmation that DBCC execution has completed. You can just type exit at the command prompt to exit.Open Task Manager > Process Tab and review the sqlservr.exe and confirm that memory usage has decreased.
Best of luck..

Guyana Linux Users Group Snort installation July 7, 2009

Posted by daakeung in IT, Linux, Uncategorized.
Tags: , , , , , ,
add a comment

Every month now, GLUG meets up to discuss and share ideas.  Last GLUG meeting I volunteered to do an installation of SNORT on CENTOS and live demonstration.  It was a privilege to contribute to such a growing community in Guyana. Also Mike Harrison of Utiliflex took part to offer us his valuable experience and motivation.

Download: snort_installation_presentation

Cisco Dual Wan Fail-Over using SLA Tracking July 3, 2009

Posted by daakeung in Cisco, IT.
Tags: , , , , ,
16 comments
Maintaining a high availability connection is critical in any modern network infrastructure.  Some would have access to the internet via multiple ISPs.
In most cases where the ISPs would not peer via any routing protocol, customers are left to setup fail-over with static routes.
There are two types of failures:
  1. Physical : the router would detect one of its interface not connected, invalidated any next hop routes through it. In turn move to another valid route with a higher metric.
  2. Logical : the router has it’s interface online, but somewhere along the path it has to take to reach the destination is unavailable.
Basic router commands with higher metric will not fail-over with a logical failure.
Using SLA Tracking, we can accomplish this.
Consider the following diagram and configuration:
Cisco Dual WAN

Cisco Dual WAN

Cisco IOS used: c181x-adventerprisek9-mz.124-24.T

! Identify the SLA.
ip sla 10

! Set up the IP address to ping, in this case yahoo.com ip.
icmp-echo 69.147.114.224

! Set how long in milliseconds to wait for a reply.
timeout 1000

! Repeat Rate.
frequency 3

! Start SLA 10 from now to forever.
ip sla schedule 10 life forever start-time now

! Setup track 10 to sla 10 for reachabilty.
track 10 ip sla 10 reachability

! Setup route for testing reach ability to the internet.
ip route 69.147.114.224 255.255.255.255 10.0.0.1

! Setup primary link with track 10 parameter.
ip route 0.0.0.0 0.0.0.0 10.0.0.1 track 10

! Setup fail-over link with higher metric.
ip route 0.0.0.0 0.0.0.0 192.168.0.1 20
Depending on your configuration, you will need to setup NAT on both interfaces.

How Save Outlook Auto Complete List June 18, 2009

Posted by Gomez in E-Mail, IT, Microsoft.
Tags: , , , ,
add a comment
I recently had a client who wanted to preserve their email list (auto complete cache), so here’s how to perform this neat little task.

Outlook 2003 and Outlook 2007 have a feature called Email Address Auto Complete. As you type in an email address into the TO:, BCC or CC: field outlook will display a list of matching email addresses from the outlook auto-complete cache.

 Example of Outlook Auto Complete

Ok now we know what auto complete is, let located the file;

Close Outlook.

Open Windows Explorer and enter the following address in the Address bar: %appdata%\Microsoft\Outlook (this is the same as drive:\Documents and Settings\username\Application Data\Microsoft\Outlook) Windows Explorer will update to the appropriate Outlook folder. In this folder you would see the .nk2 file(s). Now to explain every Microsoft Outlook profile will have its own .nk2 file e.g. the default profile name is outlook so you will see the outlook.nk2 file. Just make a copy backup of this file, that’s all to it, you are done!

 If you are not too sure what your current profile(s) are you can open mail icon in control panel and on the Mail Setup – Outlook dialog box, client on Show profile, here you can see all your default profiles.

Now let’s say that on the computer you want to restore/replace the outlook.nk2 file has a different profile name e.g. exchangepro is the name of the profile on the target computer, all you need to do is navigate to: %appdata%\Microsoft\Outlook, paste the outlook.nk2 file then rename it to profilename.nk2 (in this example exchangepro.nk2). Open Microsoft outlook and enjoy.

Where are my CALS? June 13, 2009

Posted by Gomez in IT, Microsoft, Network Services.
Tags: , , ,
1 comment so far

For all my fellow Small Business Server users, this week I was greeted with an issue with one of my client’s informing me that they are not able to access the mapped network drives “Connection to resource has exceeded maximum connections” After extensive searching in Event Viewer > System logs, I came across the following entry;

Event Type:        Error
Event Source:    SBCore
Event Category:     None
Event ID:              1023
Date:                     6/11/2009
Time:                     7:08:27 PM
User:                     N/A
Computer:          XXXXXX
Description:
The license store for the client access licenses is not valid. Only the minimum number of client access licenses will be available until a valid license store is restored. For more information, see Help in the Licensing snap-in.

 Open Server Management > Licenses, found that  installed CALs (50 Client access licenses) disappeared leaving only the default “5”. 

There are three main methods for restoring the License Store.

Method 1: If you had previously exported the license store after entering the CALS and activating them, you can simply restore that file.

Method 2: If you have the actual CAL codes you can re-enter and activate the CALS.

Method 3: If you have a backup of your system drive you can locate the file licstr.cpa which is located in %systemroot%/system32  folder. Simply replace this file on your affected system with the previously backed up licstr.cpa.  (This method was the one that worked in my situation)

Now after you have restored the licstr.cpa file in its original location, be sure to restart the license logging service.

Word of caution for those who have not experience this issue, take a backup of your license store!

Cisco OSPF and Windows RRAS OSPF May 24, 2009

Posted by daakeung in Cisco, IT, Microsoft.
Tags: , , ,
1 comment so far

I’ve been battling with getting Windows RRAS ospf and Cisco ios ospf to become neighbours for the past few days.

If you turn on ospf debug in windows and the following shows up :

Rejected an OSPF packet from x.x.x.x to 224.0.0.5 because the OSPF data length in the OSPF header was 48 but the length calculated from the IP Header fields was 60.

You should disable the following on the cisco ios:

router ospf 100

no capability lls

Also, if you are running ISA with RRAS you should disable  “block fragmentation”

For more information:

http://technet.microsoft.com/en-us/library/cc302678.aspx#NetworkAndRoutingIssues

http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_c1g.html#wp1036468

Using Cisco IOS to determine Serial Number May 8, 2009

Posted by daakeung in Cisco, IT.
Tags: , , , ,
add a comment

Have any of you ever had to find out the S/N of a remote cisco ios device?

You can issue the following IOS command:

show inventory

This produces the PID, the MODEL number of the device and also the Serial Number, this can be useful when auditing your network.

Small Business Server 2003 POP3 Connector April 19, 2009

Posted by Gomez in E-Mail, IT, Microsoft.
Tags: , , , , ,
1 comment so far

Small Business Server 2003 users that use the POP3  Connector Manager and are affected by that annoying 15 minutes download interval, finally there is hope, here is a registry tweak to drop the interval from 15 minutes to 5 minutes;

FIRST. Take a backup of your registry

1. Open Regedit
2. Navigate to HKEY_LOCAL_MACHINE/SOFTWARE/Micro­ soft/SmallBusinessServer/Network/P­OP3 Connector
3. Create a new “DWORD value” and type “ScheduleAccelerator” as the entry name
4. Select the DWORD and on the edit menu click modify, in the value box, type 3 and ensure the Decimal Radio button is clicked on the right.

(To determine the polling interval, the value that is configured on the “Scheduling” tab in the GUI is divided by the value that you type for the ScheduleAccelerator entry, example, if a 15 minute interval is specified in the GUI and you set the value of the ScheduleAccelerator entry to 3, the connector will poll ever five minutes, If you make it too short there can be problems with the POP3 connector starting a download before the previous download has started, it seems to work well with 5minutes)

5. Exit Regedit

HTTP/1.1 503 Service Unavailable April 9, 2009

Posted by Gomez in E-Mail, IT, Microsoft, Network Services.
Tags: , , ,
3 comments

After typing http://Server-name/exchange
You get the login box, after entering the correct user info you get the dreaded
HTTP/1.1 503 Service Unavailable, after searching the web for months and tried almost all available tutorials I finally found the solution. This problem (the scenario I experienced) it relates to permissions in the windows registry. Follow the steps below to get OWA working as normal.

1. Open regedit from the command prompt, ensure you take a backup of your current registry configuration. To export, on the file menu in registry editor click export  and choose save destination

2. Locate and Right Click HKEY_CLASSES_ROOT hive and select Permissions

3. Click the Advanced button on the Permissions dialog box

4. Highlight CREATOR OWNER – make sure this is the user selected

5. Tick the box for Replace permission entries on all child objects

6. Click OK twice

7. Its best to restart the server, but if you are anxious just restart all exchange services

8. Finally Test 
 
 
 

 

Setting up onboard Dialout v.92 modem on cisco 1811 April 9, 2009

Posted by daakeung in Cisco, IT.
Tags: , , , ,
add a comment

I’ve trolled the internet looking for ways to configure the v92 modem on a cisco 1811, and have managed to paste together pieces to make a dialup connection from the router, please note this configuration will not work with the aux port.

interface Async1
no ip address
ip nat outside
ip virtual-reassembly
encapsulation ppp
no ip route-cache cef
no ip route-cache
dialer in-band
dialer pool-member 1
dialer-group 1
async mode interactive

!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
no ip route-cache cef
no ip route-cache
dialer pool 1
dialer remote-name ***ISP NAME***
dialer idle-timeout 2000
dialer string ***NUMBER***
dialer hold-queue 10
dialer-group 1
no peer default ip address
ppp authentication pap chap callin
ppp chap hostname ***USERNAME***
ppp chap password 0 ***PASSWORD***
!

access-list 123 permit ip any any — Modify this to mark interesting traffic to bring up the Dialup Connection.
dialer-list 1 protocol ip list 123